Make your own free website on Tripod.com
[ctr]

QtEZ-0.77.x development page

Optimized for Lynx

This page has been created to host the bleeding-edge releases of QtEZ, the famous Qt/KDE GUI builder by Sam Magnuson.


QtEZ---Qt/KDE GUI creation environment


Primary Site of the author: http://qtez.zax.net/qtez/
Download version 0.77.2: qtez-0.77.2.tar.gz (764,176 Byte)
NEW: Visit this Slovak QtEZ page by Jan Prokop!

This is how I tested that this archive works:

Following are precompiled Linux binaries of the program. They are compiled -march=i386 -mcpu=k6 -O6 against libc5, so they will run on any x86 compatible box, but are aligned for speed on faster machines.

qtez-0.77.2 Linux libc5 Qt-only stripped binary (314,607 Byte)
Be aware! This one links against (here; ldd output):
        libqt.so.1 => /usr/local/qt/lib/libqt.so.1 (0x4000d000)
        libdl.so.1 => /lib/libdl.so.1 (0x401ee000)
        libm.so.5 => /lib/libm.so.5 (0x401f1000)
        libc.so.5 => /lib/libc.so.5 (0x401fa000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x402bd000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x4034f000)
        libXThrStub.so.6 => /usr/X11R6/lib/libXThrStub.so.6 (0x40359000)
(At least KDE 1.1 or a very recent 1.1 beta is required.)

Also, I have a precompiled KDE version available (also supports generation of KDE applications):
qtez-0.77.2 Linux libc5 Qt/KDE stripped binary (308,856 Byte)
Be aware! This one links again these libs: (make sure you have recent libs available; it has been compiled against Qt-1.42. You don't need to have libXThrStub.so, since it is only needed for multi-threaded X11.)
It links against:
        libkdecore.so.2 => /opt/kde/lib/libkdecore.so.2 (0x4000d000)
        libkdeui.so.2 => /opt/kde/lib/libkdeui.so.2 (0x400b0000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x401a1000)
        libqt.so.1 => /usr/local/qt/lib/libqt.so.1 (0x401ab000)
        libdl.so.1 => /lib/libdl.so.1 (0x4038c000)
        libm.so.5 => /lib/libm.so.5 (0x4038f000)
        libc.so.5 => /lib/libc.so.5 (0x40398000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x4045b000)
        libXThrStub.so.6 => /usr/X11R6/lib/libXThrStub.so.6 (0x404ed000)

More exact information: The binaries have been linked against Qt-1.42, KDE-1.1 and libstdc++-2.9.0, which is statically linked (so you don't have to worry about whether your C++ library will work with the file).

If you encounter problems, please contact me at <j.tevessen@gmx.de>.

Save the whale.

ciao,
johnny

Back to my homepage
Save the whale